ATENÇÃO!
Este fórum está disponível apenas para pesquisa.

Problema Apache X PHP para colocar Joomla

Dúvidas referentes a instalação, Upgrade ou Migração do Joomla!
lsantanan
Novato
Mensagens: 1
Registrado em: 20 Abr 2011, 13:51

Problema Apache X PHP para colocar Joomla

Mensagem por lsantanan »

Olá Pessoal, tudo bom? Bom dia!

Estou com um problema ao startar o apache 2.2.17 com o PHP 5.2.17. Ocorre o erro abaixo (numa janela pop up) ao clicar no botão "start" no Apache Service Monitor:

"The request operation has failed"

Quando eu edito o arquivo httpd.conf para o modelo abaixo, o apache starta normalmente:

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
#PHPIniDir "C:\PHP\"
#LoadModule php5_module "C:\PHP\php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL


Porém, quando eu tiro o comentário, ocorre o erro mencionado acima:

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:\PHP\"
LoadModule php5_module "C:\PHP\php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL



Já editei o arquivo host

de:

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost

para:

# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
# ::1 localhost

porém o erro continua.

Desistalei e reistalei tudo novamente (inclusive exclui as pastas do PHP e Apache), porém o mesmo erro insiste em ocorrer.

no PHPIniDir e LoadModule php5_module, já usei tanto / e // quanto \ e \\

No log do Apache, aparece a mensagem:

[Wed Apr 20 11:10:17 2011] [notice] Child 15668: Child process is running
[Wed Apr 20 11:10:17 2011] [notice] Child 15668: Acquired the start mutex.
[Wed Apr 20 11:10:17 2011] [notice] Child 15668: Starting 64 worker threads.
[Wed Apr 20 11:10:17 2011] [notice] Child 15668: Starting thread to listen on port 80.
[Wed Apr 20 11:10:23 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Wed Apr 20 11:10:23 2011] [notice] Child 15668: Exit event signaled. Child process is ending.
[Wed Apr 20 11:10:24 2011] [notice] Child 15668: Released the start mutex
[Wed Apr 20 11:10:25 2011] [notice] Child 15668: All worker threads have exited.
[Wed Apr 20 11:10:25 2011] [notice] Child 15668: Child process is exiting
[Wed Apr 20 11:10:25 2011] [notice] Parent: Child process exited successfully.
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.0.185 for ServerName

Sendo que a primeira parte é log de sucesso (quando eu comento PHPIniDir e LoadModule php5_module no httpd.conf e a última linha é o erro, de quando não está comentado.

cheguei num ponto que não sei mesmo o que ocorre. Alguém tem alguma idéia?


Estou fazendo o procedimento em um Windows 7 home premium 64b

Agradeço desde já
Responder