ATENÇÃO!
Este fórum está disponível apenas para pesquisa.

Re:Caracteres Inválidos

Fórum aberto para se debater Correções e Sugestões da tradução do Mambo 4.5.2.
Avatar do usuário
Gustavo Fernandes
Novato
Mensagens: 2
Registrado em: 12 Set 2004, 18:33

Caracteres Inválidos

Mensagem por Gustavo Fernandes »

Instalei o Mambo 4.5.2.1-BR-Estavel e aparece vários caracteres inválidos que são substituiídos por um losangulo com um ponto de interrogação. A instalação, o Painel Admin e o Site está cheio deles.

Tem como ajeitar isso?

Estou rodando em localhost, usando o Kubuntu Linux 5.04 e Firefox pt_BR 1.02
FaBMak
Super Joomleiro
Mensagens: 1245
Registrado em: 17 Jul 2008, 23:43

Re:Caracteres Inválidos

Mensagem por FaBMak »

Tenha certeza que a configuração de Localidade esta setada para pt_BR. Se estiver o problema é no seu linux.

Tive um problema parecido usando o Ubuntu que foi resolvido executando o comando dpkg-reconfigure locales, daí vc acrescenta o pt_BR-ISO8859-1 e seta ele como padrão. Este problema ocorre porque o Mambo usa o ISO-8859-1 e Ubuntu/Kubuntu o UTF-8 como codificação de caracteres.

FaBMak
Avatar do usuário
Gustavo Fernandes
Novato
Mensagens: 2
Registrado em: 12 Set 2004, 18:33

Re:Caracteres Inválidos

Mensagem por Gustavo Fernandes »

Valeu pela dica, ele estava configurado para pt_BR mas não esse ISO. Acho que agora foi resolvido o problema! ;)

Postagem editada por: Gárgula, a: 18/04/2005 09:21
Júlio César Barbosa
Novato
Mensagens: 6
Registrado em: 18 Set 2004, 07:52

Re:Caracteres Inválidos

Mensagem por Júlio César Barbosa »

O meu problema além desse, dos caracteres inválidos no Ubuntu, que já havia arrumado, o mambo, na primeira página de instalação diz que o Mysql não está disponível, porém, estou rodando o phpmyadmin e está ok. Alguém tem alguma idéia do que está acontecendo? :(
FaBMak
Super Joomleiro
Mensagens: 1245
Registrado em: 17 Jul 2008, 23:43

Re:Caracteres Inválidos

Mensagem por FaBMak »

julioxper escrito:
O meu problema além desse, dos caracteres inválidos no Ubuntu, que já havia arrumado, o mambo, na primeira página de instalação diz que o Mysql não está disponível, porém, estou rodando o phpmyadmin e está ok. Alguém tem alguma idéia do que está acontecendo?
Tente revisar os seus passos para ver onde está o erro, tenha certeza de estar usando um usuário MySQL que tenha permissão de criação de tabelas, verifique também se não é o firewall que está bloqueando o acesso ao MySQL e o mais importante tenha certeza que está colocando "localhost", sem aspas, no Nome do Servidor na tela de instalação do Mambo, pois o Ubuntu só aceita conexões MySQL via loopback.

FaBMak
Júlio César Barbosa
Novato
Mensagens: 6
Registrado em: 18 Set 2004, 07:52

Re:Caracteres Inválidos

Mensagem por Júlio César Barbosa »

Primeiramente obrigado pelas dicas. Já chequei as opções que você encaminhou, mas mesmo assim não funcionou. Esta é a mensagem que recebo na tela de início. Uso o phpmyadmin que funciona perfeitamente, também estou usando o Mysqlcc e não estou tendo nenhum problema em acessar a base de dados... [img size=430]http://www.mambobrasil.org/components/c ... boinfo.jpg[/img]
Júlio César Barbosa
Novato
Mensagens: 6
Registrado em: 18 Set 2004, 07:52

Re:Caracteres Inválidos

Mensagem por Júlio César Barbosa »

Consegui resolver, a extensão \"extension=mysql.so\" estava comentada no php.ini
FaBMak
Super Joomleiro
Mensagens: 1245
Registrado em: 17 Jul 2008, 23:43

Re:Caracteres Inválidos

Mensagem por FaBMak »

Bom isto geralmente ocorre porque o php padrão do Ubuntu não tem a extensão MySQL instalada, sendo assim vc vai precisar instalar o pacote php4-mysql disponível no repositório Universe.
Vc já tem este pacote instalado ? Se tem qual versão do MySQL instalada ?

FaBMak

Postagem editada por: FaBMak, a: 29/04/2005 01:19
Responder